вторник, 26 апреля 2011 г.

Обновление мира. Gentoo

Пару месяцев не обновлял gentoo. Сегодня решил обновиться и получил вот такое:
!!! All ebuilds that could satisfy "virtual/ffmpeg" have been masked.
!!! One of the following masked packages is required to complete your request:
- virtual/ffmpeg-0.6.90 (masked by: EAPI 4)
- virtual/ffmpeg-0.6-r1 (masked by: EAPI 4)

The current version of portage supports EAPI '3'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
Решение нашлось. Для начала следует обновить portage.
emerge -u portage
Правда после этого при попытке обновить мир мы получим примерно следующее:
emerge: there are no ebuilds built with USE flags to satisfy ">=media-video/ffmpeg-0.6[X=,encode=,mp3=,sdl=,theora=,threads=,vaapi=,vdpau=,x264=]".
!!! One of the following packages is required to complete your request:
- media-video/ffmpeg-0.6_p25767 (Change USE: -threads -x264)
- virtual/ffmpeg-0.6-r1 (Change USE: +x264 +threads)
(dependency required by "virtual/ffmpeg-0.6-r1" [ebuild])
(dependency required by "media-sound/audacity-1.3.12" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Но и это тоже решается:
echo "virtual/ffmpeg threads" >> /etc/portage/package.use
Далее обновляемся и радуемся жизни :)